View Issue Details

IDProjectCategoryView StatusLast Update
0002300DCP-o-maticFeaturespublic2022-12-14 19:37
Reportercarl Assigned Tocarl  
PriorityhighSeverityminorReproducibilityN/A
Status resolvedResolutionfixed 
Target Version2.16.36 
Summary0002300: Change how time zones are handled for KDMs
Description

Cinema UTF offsets often change with daylight savings time (at different times in different countries etc.) so having a UTC offset per cinema is awkward. Instead, we should add a UTC control to the KDM time, then use that to fill in KDM timestamps using the -00:00 notation (i.e. time is in UTC and we don't know how that relates to the local time zone).

e.g. if we're in the UK on BST we enter 14:00 to 16:00 and a UTC offset of +2, then the KDMs get written as 12:00-00:00 to 14:00-00.

TagsNo tags attached.
Branch2300-kdm-timing
Estimated weeks required
Estimated work requiredUndecided

Activities

carl

2022-11-29 12:39

administrator   ~0005341

See https://www.rfc-editor.org/rfc/rfc3339#page-5 section 4.3

carl

2022-11-29 21:02

administrator   ~0005342

Not sure now of the point of using -00:00...

Say we have some country A which is UTC -04:00 i.e. 14:00 in UTC is 10:00 in country A.

And we're making a KDM for country A. We want to enter the validity time there, not here. DoM can't know what time zone a particular country is in, so we must tell it the time zone.

This is what we tried to do so far with the UTC offset in Cinema. But that doesn't work because UTC offset changes through the year.

Now we're suggesting in the UI, we want the KDM to start at 17:00 local time, so we say

17:00 UTC-4

(i.e. 21:00 UTC) and into the KDM we we write 17:00T-04:00.

Not sure what the benefit is of writing 21:00T-00:00 as this report suggests.

carl

2022-12-03 23:49

administrator   ~0005351

This also feels like quite a big change that should maybe end up in 2.17.x

carl

2022-12-13 20:59

administrator   ~0005361

Running tests of 2300 libdcp branch against DoM, then merge that to libdcp main, then merge this to 2.17.x

carl

2022-12-14 19:37

administrator   ~0005363

a7ba9ea0f6a896821f9c9540fd7bbedfc059cf42 in v2.17.x

Issue History

Date Modified Username Field Change
2022-08-17 15:37 carl New Issue
2022-08-17 15:38 carl Assigned To => carl
2022-08-17 15:38 carl Status new => acknowledged
2022-08-28 23:37 carl Target Version 2.16.22 => 2.16.23
2022-09-03 21:03 carl Target Version 2.16.23 => 2.16.24
2022-09-04 13:16 carl Target Version 2.16.24 => 2.16.25
2022-09-11 08:37 carl Target Version 2.16.25 => 2.16.26
2022-09-18 20:55 carl Target Version 2.16.26 => 2.16.27
2022-09-24 21:55 carl Target Version 2.16.27 => 2.16.28
2022-09-28 23:48 carl Priority normal => high
2022-10-05 17:48 carl Target Version 2.16.28 => 2.16.30
2022-10-12 11:53 carl Target Version 2.16.30 => 2.16.31
2022-10-19 19:47 carl Target Version 2.16.31 => 2.16.32
2022-10-26 19:07 carl Target Version 2.16.32 => 2.16.x
2022-11-22 22:48 carl Target Version 2.16.x => 2.16.35
2022-11-22 22:48 carl Estimated work required => Undecided
2022-11-29 09:46 carl Status acknowledged => in progress
2022-11-29 09:46 carl Branch => 2300-kdm-timing
2022-11-29 12:39 carl Note Added: 0005341
2022-11-29 21:02 carl Note Added: 0005342
2022-11-30 21:25 carl Target Version 2.16.35 => 2.16.36
2022-12-03 23:49 carl Note Added: 0005351
2022-12-13 20:59 carl Note Added: 0005361
2022-12-14 19:37 carl Status in progress => resolved
2022-12-14 19:37 carl Resolution open => fixed
2022-12-14 19:37 carl Note Added: 0005363